Ir para conteúdo
  • Cadastre-se
Hbj

GPS do iPhone 5s é uma porcaria! (?)

Posts Recomendados

Deverias correr não com o wifi habilitado, mas sim com o 3G ou 4G habilitado.

 

Sério? No Lumia a qualidade do GPS era perfeita, mesmo offline. Exemplo:

 

0Z5JVtO.png

 

Aqui é interior e minha operadora é TIM, portanto internet no celular eu só uso em casos extremos e quando não há outra opção. De qualquer forma, obrigado pela dica. Vou testar...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ao invés de por o iPhone no modo avião desliga só o 3G e vê o que acontece. E veja no app bússola se mostra mesma latitude e longitude.

O iPhone é um aparelho tão visado que se o GPS fosse ruim isto seria gritado aos quatro ventos pela internet.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ao invés de por o iPhone no modo avião desliga só o 3G e vê o que acontece. E veja no app bússola se mostra mesma latitude e longitude.

O iPhone é um aparelho tão visado que se o GPS fosse ruim isto seria gritado aos quatro ventos pela internet.

 

Eu não colocava o iPhone em modo avião. Só não deixava o uso de dados habilitado. A bússola e localização no mapa batem certinho.

 

Reinstalei o app e a qualidade do traçado melhorou bastante. Ainda tem alguns pontos que ele dá um "nó", porém no geral já está aceitável. No treino de hoje a diferença de percurso capturada pelo Runtastic no iPhone foi "apenas" 200 metros a mais que o Lumia 720 do meu amigo. Mas isso já serve para deixar claro que o problema era/é no aplicativo (ainda vou testar outros para confirmar).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aqui eu utilizo o TomTom e o Nike+ com o GPS do aparelho, e a precisão é excelente.

 

Eu deixo tudo habilitado (Wi-Fi, 3G, e etc), mas é por costume mesmo.

 

Abraços.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deixar o wi-fi habilitado melhora a precisão do GPS. Pelo menos é o que o Runtastic diz...

 

2199e77.png

 

Aparentemente reinstalar o app resolveu o problema. Vejam um comparativo do antes e do depois:

 

ANk8bY3.pngfd4uByb.png

 

Seu eu abrir o mapa no site do Runtastic e aproximar bem, ainda consigo achar algumas loucuras. Ainda pretendo fazer alguns testes com outros apps para descobrir se a culpa disso é do GPS do iPhone ou do Runtastic.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Hbj, só por desencargo de consciência, faz um teste com o wi-fi e 3g ligado. Ele (e todos os outros) usam o a-gps, que usa dados de triangulação de antenas para melhorar a localização. O wi-fi ligado é para triangular com as redes também.

 

Faz o teste e posta aqui.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu fiz um teste aqui com o meu iPhone 4 usando esse app Rustatic, correndo em uma "pista de cooper", a maior diferença que deu em relação a marcação da pista foi de 2 mts, acho excelente. Lembrando que não é uma pista oficial, e sim uma marcação no caminho em um parque da Prefeitura, ela pode não estar perfeita também. Wi-fi e 3G sempre ligados, por costume mesmo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Galera, finalmente consegui fazer alguns testes. Como relatei anteriormente, reinstalar o app Runtastic deu uma boa melhorada no traçado do GPS. Até achei que o problema estava resolvido. Só que ele voltou pouco tempo depois, ou seja, eu estava certo que o problema era no aplicativo.

 

Para comprovar isso, resolvi migrar para o RunKeeper e adivinhem? Ele apresenta exatamente o mesmo problema. Veja a imagem da minha última corrida: http://i.imgur.com/oCJwzQR.png

 

Reparem que no início do trajeto (marcação em verde) o traçado está aceitável e depois vai piorando até chegar nisso que vocês veem na imagem.

 

Ah, também fiz um teste com o 3G ligado usando os dois apps (Runtastic e RunKeeper, um de cada vez). Infelizmente eu acabei deletando o "treino" e esqueci de tirar screenshot do resultado. Mesmo com a rede de dados, o traçado ficou pior que o meu antigo Lumia e o Moto X do meu amigo, ambos com o 3G desabilitado.

 

Bom, acho que já tenho a confirmação que precisa: realmente meu iPhone está com o GPS zicado. Vou entrar em contato com a Apple e mandar o aparelho para a garantia.

 

Agradeço a todos pela ajuda, comentários e sugestões! Obrigado!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom, não sei se vai ajudar. Comprei meu primeiro iPhone 4S e o Google Maps nunca funcionou. Waze, Moves, Run 3K!, tudo funcionando perfeitamente. Achei que era problema no celular mas tava desconfiado... Enfim.. Foi quando pulei para meu iPhone 5: "Google Maps funcionando perfeitamente!". Tente ver outro iPhone do mesmo modelo de outra pessoa e veja se dá o mesmo problema. Aí é batata, troque o celular. Hoje em dia é difícil ter problemas de tamanha gravidade que sejam do app. Só quando o defeito é aparente mesmo.. Dá para notar na hora.

 

Espero ter ajudado. Abs.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pois é, o ruim é que não conheço ninguém que possui um iPhone 5s (ou qualquer outro iPhone). Meus únicos pontos de referência são o Lumia 710, o Moto X (ambos de um amigo que corre comigo) e o meu antigo Lumia 820. Todos esses apresentam um excelente resultado no Runtastic, com um traçado perfeito mesmo sem o 3G ligado.

 

Não entra na minha cabeça a possibilidade de um aparelho que custa até 7x mais que um Lumia [520] apresente tamanha discrepância de qualidade do GPS. A única coisa que eu consigo imaginar é que o aparelho realmente está com defeito.

 

De qualquer forma, ainda não tentei restaurar o iPhone. Vou fazer isso antes do próximo treino (amanhã), configurá-lo como novo (ou seja, sem restaurar o backup) e fazer um teste.

 

Obrigado pelo comentário! Abraço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Você tem notado se o App atualizou recentemente e com isso os resultados melhoraram? lembro que li uma enxurrada de críticas quanto a precisão desse APP junto ao GPS, que de fato o GPS do iPhone não tinha culpa na falta de precisão, basta ler as resenhas dele na App Store.

 

Tenho um 5S e esse mesmo APP, meu trabalho é cerca de 2,5km da minha casa, vou fazer o teste com Wifi ligado e desligado.

Editado por Alex Leal

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então, a última atualização do Runtastic foi dia 17/01 e do RunKeeper foi dia 06/02. Meu iPhone chegou dia 18 e migrei para o RunKeeper esses dias. A única melhora que eu notei foi quando reinstalei o Runtastic, mas logo tudo voltou ao "normal". 

 

Hoje eu restaurei o iPhone configurei como novo, sem recuperar o backup. Instalei o RunKeeper e iria fazer um teste, porém começou a chover e não deu. Mas eu dei umas voltas de carro com ele ligado e notei algumas falhas (imagens: http://imgur.com/a/hKsZy#0). Já havia feito outros testes de carro e o traçado fica mais preciso (acho que a velocidade deve ter influenciar). O problema maior é quando caminho/corro mesmo.

 

Também notei que o GPS demora um pouco para me localizar no mapa e o ponto da umas voltas malucas. Não sei se tem alguma coisa a ver com o problema, mas fiz um vídeo para mostrar: https://www.dropbox.com/s/ru50bybmtl3tprv/Clip%20%231.mov

Será que isso é normal? Acontece com mais alguém?

 

Quando der, Alex, faça o teste e poste o resultado, por favor. Desde já obrigado! Abraço!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal, será que fazer um daqueles vídeos martelando o celular e postar no YouTube resolve? Liguei no suporte e relatei todo o problema, que ele ocorre com mais de um app, que eu já tentei reinstalar o app, resetar o iPhone, etc. e mesmo assim o problema persiste. Depois de consultar o "suporte avançado", tudo que o inútil do atendente me diz é que o problema está no aplicativo e, por ser de terceiro, não tem como a Apple resolver.

 

Outra coisa relacionada ao GPS que eu notei aqui é que as fotos tiradas em um ponto ficaram espalhadas em um raio de uns 100m. É normal? Alguém pode verificar se isso também ocorre? Veja a imagem: http://i.imgur.com/15SIK3o.png Caso isso não seja normal, estou pensando em relatar esse problema ao suporte.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Seus treinos são bem mais intensos então teria que alguém fazer um teste andando ou correndo por mais de 8km! Eu não consegui testar em em percurso maior mas se ajudar andei alguns minutos monitorando. post-57446-13931571602567_thumb.jpg

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado, pessoal! Para mim já está claro que o problema é no iPhone. Só falta eu conseguir convencer a Apple disso. Nas três vezes que entrei em contato com o suporte, eles me disseram que a culpa é do Runtastic/RunKeeper e me recomendaram entrar em contato com o suporte do app, praticamente ignorando o fato do mesmo problema acontecer em dois apps. Qual a probabilidade dos dois principais aplicativos do gênero estarem bugados?

 

Eu sei que é complicado explicar isso por telefone e talvez eu tenha falhado, mas estou bem decepcionado com o pós-venda da Apple. Eles simplesmente ignoram meus argumentos e batem na mesma tecla: por se tratar de apps de terceiros, eles não podem fazer nada. Um dos atendentes chegou a dizer que o problema não é no meu iPhone, é no GPS. Ou seja, só pode ser no satélite...

 

Vou fazer tudo que me foi recomendado antes de entrar em contato com o suporte novamente (contatar o(s) desenvolvedor(es) do(s) app(s) e a TIM, minha operadora [?!]), só para zerar os argumentos do "suporte especializado em GPS". Já adianto que está complicado. Comprei o aparelho no Brasil e paguei pela garantia/suporte, mas quem está tendo que correr atrás de tudo sou eu...

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      47.919
    • Total de Posts
      410.573
×
×
  • Criar Novo...