Ir para conteúdo
  • Cadastre-se
Jorge Maia

iWork em sistema anterior ao 10.5.6

Posts Recomendados

Pessoal,

Não sei se isso já é conhecido por aqui, mas segue a dica.

Tenho um hackintosh rodando o Leopard 10.5.4. Por motivos óbvios, não dá para atualizar para o 10.5.6 tão facilmente. Mas queria rodar o iWork 09 para experimentar e aparecia a mensagem que eu deveria atualizar meu sistema para o 10.5.6.

Pensei em "enganar" o sistema. Editei o arquivo /System/Library/CoreServices/SystemVersion.plist e alterei as strings 10.5.4 para 10.5.6. Foi o suficiente para efetuar a instalação do iWork normalmente.

Depois, alterei de volta as strings para 10.5.4 e o iWork continua iniciando normalmente.

Fica aí a dica, espero que seja útil para alguém.

Abraço,

Compartilhar este post


Link para o post
Compartilhar em outros sites

opa, como eu edito o arquivo .plist? onde posso encontrar essas "strings"? (o que sao strings?, hehe) estou no 10.5.5 mas nao quero atualizar pro 10.5.6 por causa dos jogos em cyder, e queria testar o iwork 09 pra ver se eu gosto. please, help!

Compartilhar este post


Link para o post
Compartilhar em outros sites
Estranho, tenho um iMac com Tiger e instalei o iWork 09 normalmente

Como voce fez isso? A apple ate vende um pack com o leopard junto por ser o SO minimo para a instalacao...

Compartilhar este post


Link para o post
Compartilhar em outros sites
Pessoal,

Não sei se isso já é conhecido por aqui, mas segue a dica.

Tenho um hackintosh rodando o Leopard 10.5.4. Por motivos óbvios, não dá para atualizar para o 10.5.6 tão facilmente. Mas queria rodar o iWork 09 para experimentar e aparecia a mensagem que eu deveria atualizar meu sistema para o 10.5.6.

Pensei em "enganar" o sistema. Editei o arquivo /System/Library/CoreServices/SystemVersion.plist e alterei as strings 10.5.4 para 10.5.6. Foi o suficiente para efetuar a instalação do iWork normalmente.

Depois, alterei de volta as strings para 10.5.4 e o iWork continua iniciando normalmente.

Fica aí a dica, espero que seja útil para alguém.

Abraço,

Valeu! Funcionou perfeitamente aqui no 10.5.5.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Como voce fez isso? A apple ate vende um pack com o leopard junto por ser o SO minimo para a instalacao...

Então IgorBritto, eu instalei como outro aplicativo qualquer.

E olha que o Tiger está em um iMac G3. Não digo que ficou rápido pois está bem lento, mas instalou sem problemas.

Editado por Ramon

Compartilhar este post


Link para o post
Compartilhar em outros sites
Então IgorBritto, eu instalei como outro aplicativo qualquer.

E olha que o Tiger está em um iMac G3. Não digo que ficou rápido pois está bem lento, mas instalou sem problemas.

Cara, aqui num foi mesmo, quando tento instalar o iwork diz que tenho que ter a versao mais recente do os x . eu nao vou atualizar pois o 10.5.6 tranca os jogos em cider. até eu comprar um mac novo fica o iwork 08 mesmo (o ilife eu nem uso, entao nao tem problema). valeu!

Editado por IgorBritto

Compartilhar este post


Link para o post
Compartilhar em outros sites
Cara, aqui num foi mesmo, quando tento instalar o iwork diz que tenho que ter a versao mais recente do os x . eu nao vou atualizar pois o 10.5.6 tranca os jogos em cider. até eu comprar um mac novo fica o iwork 08 mesmo (o ilife eu nem uso, entao nao tem problema). valeu!

O meu GTA:SA do cider funciona normal no 10.5.6

Compartilhar este post


Link para o post
Compartilhar em outros sites
Cara, aqui num foi mesmo, quando tento instalar o iwork diz que tenho que ter a versao mais recente do os x . eu nao vou atualizar pois o 10.5.6 tranca os jogos em cider. até eu comprar um mac novo fica o iwork 08 mesmo (o ilife eu nem uso, entao nao tem problema). valeu!

IgorBritto,

Um outro usuário disse que o iWork precisa da última versão do Mac OS X Tiger ou Leopard. Pade ser em qualquer um, desde que seja a mais recente.

Compartilhar este post


Link para o post
Compartilhar em outros sites
O meu GTA:SA do cider funciona normal no 10.5.6

Mas li que tranca o FarCry, NFSMW e HL2 principalmente HL2 que foi portado de uma versao antiga do cider. valeu!

@ Ramon,

Dessa eu nao sabia mesmo, acho que a apple poderia esclarecer pelo menos, ou entao ela nao quis divulgar isso pra poder vender o pacote com iwork, ilife e mac os x leopard... :huh:

Compartilhar este post


Link para o post
Compartilhar em outros sites
Como que vcs editaram o arquivo .plist?

Aqui eu edito mas ele diz que eu não tenho privilégios suficientes para alterar esse arquivo.

Tava louco pra atualizar para o iWork 09 mas não estava afim de passar pro 10.5.6

Valew!

Fábio,

Você precisa editar como administrador. Faça o seguinte:

1. Abra o terminal

2. Vá para o diretório onde tem o arquivo (cd /System/Library/CoreServices)

3. Edite com o pico, utilizando o "sudo" (sudo pico SystemVersion.plist)

4. Substitua a versão que aparece lá (ex: 10.5.5) por 10.5.6. São duas ocorrências

5. Salve com Control-O e ENTER

6. Instale o iWork normalmente.

7. Depois de instalar, repita o procedimento e volte o que você alterou para o conteúdo original.

Abraço,

Jorge

Compartilhar este post


Link para o post
Compartilhar em outros sites

Em que o iWork 09 é melhor do que o 08. Pergunto isso pois tenho o 08 e trabalho apenas no Keynote e uso o Excel e Word 2008. Não testei o 09 ainda pra poder ver alguma diferença. se tambem nao for significativa acho que nem valeria a pena pagar pela inovação.

Eu tive um problema de HDD (perdi tudo) e comprei outro e tive que reinstalar todos os programas mas reinstalei o iwork 08 em ingles, e o meu antigo estava em espanhol. tem como eu trocar de lingua como faço no OSX sem ter que reinstalar tudo novamente, foi um erro na instalaçao que fiz.

Outra coisa, como não havia ainda passado por este problema, nao consegui resolver este problema que peço ajuda aqui.

Qdo projeto na tela aparecem duas imagens e no monitor do macbook somente aparece o slide atual.

onde corrijo isso?

grato a todos

Geraldo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      48.253
    • Total de Posts
      413.702
×
×
  • Criar Novo...