Ir para conteúdo
  • Cadastre-se
Eduardo Ferraiuolo

IRPF 2015 - Problemas na instalação

Posts Recomendados

Olá, amigos.
Lí as dúvidas e as dicas.
O meu caso foi diferente do da maioria, talvez por que eu sou Programador e já tinha o JDK atual instalado(pré-requisito para quem programa em java).
Pode ser também uma nova versão. Não sei. Como alguns não tem obrigação de conhecer nada de programação, eu acho que o amigo Luiz Moraes tem razão.

 

Olá!

 

A questão é: Se a Receita se propõe a lançar uma versão, seja ela pra qual plataforma for, tem que funcionar. Se fosse eles, eu deixaria uma versão com o Java embutido, muitos softwares fazem isso.

 

Só não tenham medo do Terminal. As vezes é necessário. Basta buscar a sua dúvida aqui no forum, que é muito bom quando o assunto é Devices Apple, ou outro forum de sua preferência.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Galera, resolvi esse problema de uma forma diferente. 

 

Instalei no meu mac o Java SE Development Kit 8

 

Disponível nesse site: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

 

Arquivo:   jdk-8u40-macosx-x64.dmg

 

Pronto, funcionou tudo perfeitamente.

 

Abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

Basta criar um "link virtual" entre a pasta nativa de instalação e o Path do sistema.

sudo ln -fs /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java /usr/bin/java

Obrigado! Funcionou aqui com este comando! Bem que a RFB poderia testar melhor os aplicativos antes de solta-los.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá todos, bom encontrar pessoas dispostas a ajudar. Muito obrigado mesmo. Resolvi instalar a versao multiplataforma (ZIP) e funcionou !!!!  Para poder visualizar as declaracoes dos anos anterores TAMBÉM precisei instalar a mesma versao ZIP dos anos de 2011,2012,2013,2014, caso contrario não conseguia abri-las. Meu MAC usa as versoes atualizadas do Yosemite e Java. Todos os anos é o mesmo problema com os usuários do MAC quando chega a hora do IRPF. Quem desenvolve o programa do IRPF é o SERPRO, e não a Receita Federal. Também não me conforme de não poder utilizar o programa para MAC !!!

Desisti e instalei a versão ZIP, mas também não me conformo em não poder usar a versão MAC ...
Muito obrigado a todos os que que contribuíram. Espero algum dia poder ver a versão para MAC funcionar, já que eles se propõem a isso. Até la, vou usando mesmo a versão Multiplataforma (ZIP).
Gustavo Floripa

Compartilhar este post


Link para o post
Compartilhar em outros sites

Bom dia a todos.

Fiz o download do programa de instalação p/ declaração do IR porém quando tento instalar recebo a notificação que a máquina virtual Java não foi encontrada no meu computador. Possuo instalada a última versão mas mesmo assim continuo recebendo este aviso, o que impossibilita a instalação. Alguém pode me dar uma luz?

 

attachicon.gifIRPF 2015.png

Oi Eduardo, tive exatamente o mesmo problema. E quando baixei fui instalar a tal versão do Java que ele pede, meu Mac me avisou que eu possuo uma versão mais atualizada ( a última versão ) e que tentar voltar para uma versão anterior é PERIGOSO pois pode deixar seu computador vulnerável.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá!!!

 

Eu tentei executar esse comando e não funcionou. Tentei intalar o JAVA 1.8.40.25, mas diz que eu tenho uma versão mais recente 14.9.0. Tentei procurar o plugin, pelo terminal tb, mas n encontrei.

Baixei o multiplataforma, mas tb não rolou!

Alguém pode me dar uma luz?

 

Obrigado!

Comigo acontece exatamente a mesma coisa Guilherme. Quando tento instalar a versão que o IRPF 2015 pede,  meu mac também diz que já tem uma versão posterior e que é arriscado instalar uma versão mais antiga do java. Por acaso você conseguiu solucionar? Obrigado. Marcos

Compartilhar este post


Link para o post
Compartilhar em outros sites

A mesma coisa aqui. Se você instalar o app multiplataforma funciona. Mas está errado. Se tem versão específica para Mac não deveria haver problema na instalação. Eles sugerem a versão 8.0.25 do Java (e atual que se instala é a 8.0.31) mas acredito que isso não deva ser o problema de não reconhecimento de haver Java instalado. Vamos ver se surge alguma solução. Enviei pergunta para a RFB e para o site do UOL.

O mesmo comigo Antonio e quando tento instalar a versão do Java que o IRPF 2015 pede, meu mac diz que eu já tenho uma versão mais atualizada. E li que é perigoso voltar para uma versão mais antiga do Java. Você conseguiu solucionar? Pode me ajudar? Abs. Marcos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá!

 

Esse simples symlink do do1984 resolveu tranquilo e o pessoal de matando nos comentários do post sobre isso. Eu passei esse tópico lá mas parece que a maioria ignorou.

 

Acontece que existe um temor de uso do terminal. Não é nenhum bicho de sete cabeças de usar com cuidado; o utilitário de disco pode fazer muito mais estrago, eu já apaguei um HD externo importantíssimo achando que era o pendrive, rsrsrs.

Olá Luiz, segui o seu procedimento:   

  • Copiar o comando que o ptzc sugeriu (Command+C): sudo ln -fs /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java /usr/bin/java
  • Ir na pasta Applications / Utilities (Aplicativos / Utilitários);
  • Abrir o aplicativo Terminal;
  • Colar (Command+V) e dar enter;
  • Vai pedir sua senha de usuário, digite-a mas não vai aparecer nada na tela, nem os asteriscos e dê enter;
  • Fechar o Terminal.

 

Mas não funcionou. Copiei a linha, abri o terminal e colei mas quando vou instalar ele pede aquela versão do Java mas meu Mac 10.8.5 diz que eu tenho uma versão mais nova e que é arriscado instalar uma versão mais antiga. Será que você consegue me dar alguma dica? Muito obrigado. Abs . Marcos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Joguei a toalha, a versão para Mac não rolou no Yosemite, dei comando no terminal, instalei o Kit para desenvolvedores e nada, o programa não acha o receitanet,  a solucão é a versão multiplataforma, mas tem uma pegadinha que me fez perder mais tempo ainda; é preciso jogar a pasta receitanet com a versao para mac na lixeira antes de baixar a versão da mesma para multiplataforma.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Instalei no meu MacBook White sem nenhum problema. Baixei os arquivos e inclusive instalei o programa Máquina Virtual(atual) e cliquei como botão direito do mouse no arquivo dos programas IRPF e depois em abrir, sem mistérios nenhum e já fiz 03 declarações. ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estou com um problema ao instalar o IR 2015 também.

 

A versão do OSX é a 10.9.5, porém ao instalar pede para atualizar a versão do Java.

Ao baixar a nova versão, JAVA 8 Update 40, não consigo instalar, aparece a mensagem abaixo:

 

"Uma versão mais nova já está instalada. Você está tentando instalar 1.8.40.27, mas 14.9.0 já está instalado.

Visite java.com/newerversionexists para obter mais informações."
 
Qual a solução para o caso?
 
Muito obrigado pela ajuda.
 
Rodolfo
Editado por rsemmler

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá ! Boa tarde a todos.

 

Estou com problemas para instalar o app da receita, não cosegui :

Meu computador é MacBook Pro 2,4 Ghz Intel Core 2 Duo com 10.7.5.

1) Em primeiro lugar tentei atualizar o JAVA, baixei a "mais nova" versão e ao tentar instalar apareceu a mesma mensagem do Guilherme Bicudo e do Marcos F Miranda :

"Uma versão mais nova do Java já está instalada. Você está tentando instalar 1.8.40.27, mas 14.9.0 já está instalado"
 

2) Tentei a linha de comando no terminal que "do 1984" e Luiz Moraes ensinam. Depois tentei instalar o app da receita e ele manda atualizar o JAVA.

 

3) baixei o multiplataforma mas também não roda.

 

O que fazer? Como fazer pra funcionar o  JAVA no meu computador? Alguém, por favor, tem alguma outra sugestão?

 

Obrigado !

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      48.555
    • Total de Posts
      415.249
×
×
  • Criar Novo...