Ir para conteúdo
  • Cadastre-se
leomkt

Como aumentar memória Cache e Swap no Yosemite? Navegação em video sofrível :/

Posts Recomendados

Pessoal, uso o Yosemite em um MacMini 2012 com SSD + HDD e 10Gb de Ram.

Estou assistindo a alguns cursos do site Eduk em vídeo. Imagino que alguns sejam hospedados no Vimeo, outros no Youtube, outros em outros locais. Cada aula tem duração media de 50min.

Ao assistir uma aula em alta definição, quando tento assistir a próxima aula logo em seguida ele trava MUITO. Achei que seria banda de internet, mas percebi que se eu limpar o histórico não tenho esse problema.

Imagino ser algo no Cache ou na Swap. Como faço pra configurar o tamanho dessas memórias (Cash e Swap)? É possível direciona-las ao meu HDD, e não ao SSD?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Puts.. os navegadores sugam mais memória do que PhotoShop e Lightroom juntos. Já não sei se é bom aumentar a memória cache. So ta apontando 6Mb pra troca...

Pra que isso tudo? A navegação tem ficado sofrível, não só os videos demorando pra carregar...

Editado por leomkt

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ocorre tanto no Safari quanto no FireFox. Não uso o Chrome.

 

Não são videos carregados diretamente no youtube ou Vimeo. São carregados em um site de cursos chamado Eduk, requer login. Ao rodar o video pelo curso q eu sei se ta no Vimeo ou em outro servidor de video.

 

Imagino que tenha a ver com a memoria de troca, pois quando tento assistir dois em seguida da esse erro: fica congelando, travando, o video não carrega todo.. e não guarda o que foi carregado (se volto alguns segundos, ele começa a carregar de novo).

Mas se dou intervalo de 1h ou 30 min, as vezes não da esse travamento. E se limpo o historico nunca ocorre o erro, mesmo rodando logo em seguida um video após o outro (por isso imagino que não seja a banda de internet, q é de 25mb)

 

Tb achei muito estranho. Meu SSD (onde ta o sistema) ta só 50% ocupado.

 

Acabei de ver aqui, o TRIM tava desabilitado por algum motivo :/ Depois q usei aquele comando "sudo sei la o q" pra habilitar e desabilitar automaticamente. Será que tem algo a ver?

Compartilhar este post


Link para o post
Compartilhar em outros sites

vou verificar num curso que assistir no carnaval. Como saber se é Flash ou HTML5?

A forma mais fácil é remover o plugin do Flash. Se o vídeo parar de rodar, obviamente é baseado em Flash, porém se continuar rodando é em HTML5.

O ideal seria deixar sem o Flash (porque é um comedor de bateria), mas alguns sites ainda precisam dele. Eu estou me forçando a ficar sem o Flash no sistema e minha bateria tem agradecido imensamente.

Dá pra forçar o YouTube a usar HTML5, basta acessar esse link e forçar o player nesse padrão. Testa aí e nos retorna.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então. Testei hoje. Meu Flash não esta atualizado, e não pediu pra atualizar nem barreirou o video. Acho que é HTML5. Ademais, quando clico botão direito, aparece essas opções:

post-2292-0-22730200-1454726348_thumb.jp

 

 

Sobre o uso da CPU, achei normal. Durante a exibição do video fica assim:

post-2292-0-07246800-1454726555_thumb.jp

 

Mas logo que para, volta ao normal.

 

A memória durante o video estava assim:

post-2292-0-26326900-1454726577_thumb.jp

 

E Depois do video ficou assim

post-2292-0-06662000-1454726567_thumb.jp

 

Os videos não sao carregados diretamente no Youtube. São incorporados ao site do curso, e vem de varios servidores (ja identifiquei o YouTube e o Vimeo). Como falei, devo logar pra acessar o curso.

post-2292-0-86338300-1454726709_thumb.jp

 

E quando carrego a proxima aula, vai travando. No primeiro video, o progresso de carregamento cai até o fim bem rapido, no segundo fica junto com o progresso da exibição, parando de vez em qd para carregar o video.

 

Editado por leomkt

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pelo que estou percebendo da sua explicação, não é um problema de hardware ou software porque tudo parece normal de acordo com o que você relata. Eu desconfio que pode ser um problema com o fluxo de dados entre o servidor que tem o vídeo e você, talvez sua operadora de internet realizando traffic shapping. Verifica como está o fluxo de dados de rede quando o vídeo fica travando e veja se há interrupções no download. Para testar deixe aberto apenas o navegador onde você está assistindo o vídeo.

 

Há um aplicativo muito bom que pode ajudar chamado iStats menu e tem versão trial de 14 dias. Instala ele, configura para exibir os dados que você quer na barra de menus do Mac e monitora também para este experimento CPU, GPU, memória, temperatura e tráfego de rede.

 

Você não precisará abrir o "Monitor de Atividades" para monitorar e existe um "problema" quando usamos esse método: o OS X incorporou desde o Lion um recurso chamado de App Nap. Esse recurso coloca o App que está em segundo plano em um modo de "espera" onde ele libera o uso de CPU e comprime o conteúdo do App na RAM para liberar recursos para o App que está em primeiro plano. Quando você seleciona o "Monitor de Atividades" para monitorar o sistema esse recurso coloca o App que está "por baixo" nesse modo de "espera".

 

Também existe como desativar o AppNap para cada aplicativo, caso não queira usar o iStats menu. Basta abrir a pasta aplicativos (a pasta mesmo, não o Launcher e muito menos o menu Aplicativos), clicar em cima do App que quer desativar o recurso com o control pressionado, selecionar "Obter informações" e selecionar "Impedir App Nap". Assim a monitoração do "Monitor de Atividade", quando este estiver em primeiro plano, não irá "colocar" o seu navegador em "espera".

Editado por Alan Leitão

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      48.620
    • Total de Posts
      415.707
×
×
  • Criar Novo...