Ir para conteúdo
  • Cadastre-se
Mateus Rampon

Duvida: Script de ping não roda no Crontab

Posts Recomendados

Boa tarde a todos,

 

Criei um script que pinga em alguns ip`s presentes na minha rede e faz o teste de conexão externa pingando para o google, depois de tudo feito ele retorna com um log.txt.

 

Depois de setar o script com autorização para execução no user e no root (CHMOD +X) os coloquei no crontab (CRONTAB -E). Salvei o arquivo e o sistema acusou que foi feita a instalação do Crotab mas na hora de rodar o script ele inicia e finaliza no mesmo momento não obedecendo a nenhum comando do script. Alguém sabe o que pode ser?

 

Grato, desde já.

 

 

OBS. Sou novo no fórum se não for aqui o local para discussão deste assunto peço desculpas e a gentileza de informar onde posso abrir o tópico novamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Deixa eu ver sua crontab , e seu script pode ser ? 

da um crontab -l 

Rode o script no mode debug mode 

bash -x script.sh

 

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, clandestine disse:

Deixa eu ver sua crontab , e seu script pode ser ? 

da um crontab -l 

Rode o script no mode debug mode 


bash -x script.sh

 

 

 

Crontab:

*/30 * * * * /Users/CRACKED/testedeconexao.sh

 

Arquivo:

-rwxr-xr-x@  1 CRACKED  staff    1367  7 Mar 22:22 testedeconexao.sh

testedeconexao.sh

Compartilhar este post


Link para o post
Compartilhar em outros sites

*/30 * * * *  voce quer executar a cada 30 minutos o script , voce colocou corretamente na crontab 

No meu lado o script rodou normalmente , claro que com algumas ressalvas , mais duas coisas eu pediria para voce 

Rode o script com mode debug 

coloque a permissão assim : chmod a+x script 

Abraços 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Voce executou como debug mode ? 

bash -x script.sh ? 

Execute tambem como strace no inicio do script 

Eu faria mais ou menos nessa logica o script 


#!/bin/sh

while true
do
CMD=$(ping -c1 192.168.0.2 | grep From | awk -F' ' '{ print $4 $5 $6}')
echo $CMD

if [ "$CMD" == "DestinationPortUnreachable" ];
then
#se o ip não responder mostra offline!
echo "offline"
else
#se o ip responder o ping mostra online
echo "online!"
$(sleep 1)
fi
done

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Conteúdo Similar

    • Por aka.balaumHD
      Gostaria de saber se foi coincidência ou não, mais após o ultimo update ficou tanto o Chrome e Safari com LAG, (no Chrome fica dizendo Resolvendo Host) alguém mais esta passando por isso ? ou só eu  .?  
      ABS
    • Por Ernani Filho
      Boa tarde, 
      Estou passando por uma situação interessante.
      Tenho um servidor VPN configurado no meu mikrotik. Todas as configurações estão em ordem.
      Quando tento acessar via conexão da Oi Velox, com modem ZTE ZXDSL 831II V3 e roteador WIFI D-link DIR-615, eu apenas conecto mas não consigo trocar dados na VPN já ativa.
      Quando tento acessar por outro provedor local via roteador WIFI, também não tenho sucesso.
      Quando tento acessar via conexão roteada do meu celular com operadora (TIM), a VPN funciona perfeitamente e consigo trabalhar remotamente acessando, pastas, sistemas, servidores, etc.
       Entendo que possa ser alguma configuração relacionada com os roteadores ou modem, uma vez que via roteamento do celular eu consiga navegar muito bem.
      Caso alguém tenha uma luz para me dar, sou todo "ouvidos".
      Até mais
      Ernani Filho
    • Por PedroNovak
      Olá pessoal
       
      Tem alguém por aqui que sabe utilizar bem o matlab?
      To precisando de um help em algumas coisas.. =/
    • Por Lucas Maciel
      Fala galera! Não sabia onde postar isso no fórum, aí resolvi postar aqui mesmo.
       
      Pra quem gosta de personalizar o desktop, criei um mini script para pegar os últimos post do Macmagazine e deixar fixado no desktop. 
       
      Estou usando o Geektools, que achei sem querer na net.
      Os posts são atualizados a cada 30min (da para personalizar o tempo de refresh, fonte e cor). Quem quiser é só pedir!
       
      Print do desktop, para mostrar como que fica:

      http://s29.postimg.org/y1b9c0rsn/Screen_Shot_2014_03_10_at_13_27_10.png
       
       
       
      Abraço!!!
  • Estatísticas do Fórum

    • Total de Tópicos
      47.624
    • Total de Posts
      408.124
×
×
  • Criar Novo...