Ir para conteúdo
  • Cadastre-se
JvDaP

Tutorial: MacBook Pro 2011 15 - Desabilitando GPU AMD e usar somente Intel HD Graphics

Posts Recomendados

O tutorial não é de minha autoria. Creditos: PeytonPlaysMc

Você que possui um MacBook Pro 2011 15 com problema na GPU da AMD esse tutorial pode dar uma nova vida para o seu mac.

Esse tutorial é para quem está usando macOS Sierra

1 - Entre no Recovery Mode (mode texto)

Command + R + S


2 - Desabilite SIP (Para que você possa realizar as mudanças no sistema) . SIP (csrutil) somente enable / disable no Recovery Mode.

Digite: csrutil disable


3 - Reinicie o sistema

Digite: reboot


4 - Entre no modo single user segurando as teclas 

COMMAND+S
 


5 - Check o disco

Digite: fsck -fy


6 - Monte a raiz do systems de arquivos com permissão de leitura e escrita

Digite: mount -uw /


7 - Crie um diretório para usar futuramente os drivers da AMD que serão retirados do sistema 

Digite: 
mkdir /AMD_Kexts/


8 - Mova os drivers da AMD

Digite: 
sudo mv /System/Library/Extensions/AMD*.* /AMD_Kexts/


9 - Remova o cache dos drivers da AMD

Digite: 
sudo rm -rf /System/Library/Caches/com.apple.kext.caches/


10 - Só por precaução caso o OS X não recrie um diretório para os caches, vamos recriar um diretório: 

Digite: sudo mkdir /System/Library/Caches/com.apple.kext.caches/


11 - Para facilitar a criação do novo cache sem os drivers da AMD

Digite: 
sudo touch /System/Library/Extensions/


12 - Desmonte a partição

Digite: 
sudo umount /


13 – Reinicie 

Digite: 
sudo reboot


14 - Antes de habilitar o SIP novamente, tente dar um boot normal para que o Mac OS reconstrua o kernel cache e depois reinicie. 
 

15 - Habite o SIP novamente (reinicie o sistema)


16 - Entre no Recovery Mode (modo de texto)

Command + R + S


17 - Habilite o SIP novamente 

Digite: 
csrutil enable


18 - Reinicie o sistema

Digite: 
reboot


19 - Já no sistema abra o Terminal e coloque a linha abaixo:

Digite: sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00


20 - Reinicie o sistema

Digite: 
sudo shutdown -r now
 

Se tudo ocorrer bem, conforme os passos acima, a gpu da amd está desabilitada pra sempre, forçando o sistema a usar apenas a Intel HD 3000

Fiz e deu certo

 

Editado por JvDaP

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 16/11/2017 at 19:31, JvDaP disse:

O tutorial não é de minha autoria. Creditos: PeytonPlaysMc

Você que possui um MacBook Pro 2011 15 com problema na GPU da AMD esse tutorial pode dar uma nova vida para o seu mac.

Esse tutorial é para quem está usando macOS Sierra

1 - Entre no Recovery Mode (mode texto)

Command + R + S


2 - Desabilite SIP (Para que você possa realizar as mudanças no sistema) . SIP (csrutil) somente enable / disable no Recovery Mode.

Digite: csrutil disable


3 - Reinicie o sistema

Digite: reboot


4 - Entre no modo single user segurando as teclas 

COMMAND+S
 


5 - Check o disco

Digite: fsck -fy


6 - Monte a raiz do systems de arquivos com permissão de leitura e escrita

Digite: mount -uw /


7 - Crie um diretório para usar futuramente os drivers da AMD que serão retirados do sistema 

Digite: 
mkdir /AMD_Kexts/


8 - Mova os drivers da AMD

Digite: 
sudo mv /System/Library/Extensions/AMD*.* /AMD_Kexts/


9 - Remova o cache dos drivers da AMD

Digite: 
sudo rm -rf /System/Library/Caches/com.apple.kext.caches/


10 - Só por precaução caso o OS X não recrie um diretório para os caches, vamos recriar um diretório: 

Digite: sudo mkdir /System/Library/Caches/com.apple.kext.caches/


11 - Para facilitar a criação do novo cache sem os drivers da AMD

Digite: 
sudo touch /System/Library/Extensions/


12 - Desmonte a partição

Digite: 
sudo umount /


13 – Reinicie 

Digite: 
sudo reboot


14 - Antes de habilitar o SIP novamente, tente dar um boot normal para que o Mac OS reconstrua o kernel cache e depois reinicie. 
 

15 - Habite o SIP novamente (reinicie o sistema)


16 - Entre no Recovery Mode (modo de texto)

Command + R + S


17 - Habilite o SIP novamente 

Digite: 
csrutil enable


18 - Reinicie o sistema

Digite: 
reboot


19 - Já no sistema abra o Terminal e coloque a linha abaixo:

Digite: sudo nvram fa4ce28d-b62f-4c99-9cc3-6815686e30f9:gpu-power-prefs=%01%00%00%00


20 - Reinicie o sistema

Digite: 
sudo shutdown -r now
 

Se tudo ocorrer bem, conforme os passos acima, a gpu da amd está desabilitada pra sempre, forçando o sistema a usar apenas a Intel HD 3000

Fiz e deu certo

 

Já faz um tempinho que vc escreveu mas talvez vc pode me ajudar.
digitei todos os códigos. Mas em alguns como o csrutil disable ele aparece "command not found"

Sabe me dizer o que é ?

Estava com Sierra. Mas o sistema do Mac acabou voltando para o Lion.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi pessoal, sou nova aqui!

Quem aí desabilitou e a máquina continua funcionando?

Acabei de fazer isso no meu macbook pro early 2011!

Fui testar e abaixei a tampa e ao abrir novamente, tava desligada...não liga, esperei um pouco e liguei novamente, agora foi, será que é o caso do sleep que não funciona? vi isso em outros foruns! mas como tenho 90 dias de garantia, menos mal, estou com medo de perder a máquina... se alguém puder me falar se suas máquinas funcionam bem, fico mais tranquila rsrs

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 05/06/2019 at 18:44, Fernanda Varella disse:

Oi pessoal, sou nova aqui!

Quem aí desabilitou e a máquina continua funcionando?

Acabei de fazer isso no meu macbook pro early 2011!

Fui testar e abaixei a tampa e ao abrir novamente, tava desligada...não liga, esperei um pouco e liguei novamente, agora foi, será que é o caso do sleep que não funciona? vi isso em outros foruns! mas como tenho 90 dias de garantia, menos mal, estou com medo de perder a máquina... se alguém puder me falar se suas máquinas funcionam bem, fico mais tranquila rsrs

Acabei de realizar (20/01) e está funcionando. e o seu? ainda vive? 

obrigada!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Reativando este post aqui. Alguém sabe dizer se esse procedimento funciona no meu?
No momento estou usando o APP GFX toda vez que ligo o note, mas se uso o Chrome, ou Photoshop, ele altera para a dedicada, mesmo marcando a opção "apenas integrada". O app que desabilita a GPU via software aparentemente não funciona, mas mesmo assim o habilito ao ligar o note.

A dedicada é uma NVIDIA GEFORCE GT 330M

Sou novo aqui, e faz uma semana que tenho lido tudo que posso sobre este problema, e aprendendo muito com vocês, muito obrigado.

Também queria saber se alguém já fez a troca do capacitor, já li sobre, e vi que em alguns casos funcionou.

Obrigado aí gente.

Captura de Tela 2020-04-13 às 00.04.57.png

Compartilhar este post


Link para o post
Compartilhar em outros sites
13 horas atrás, Rafael Ritta disse:

Reativando este post aqui. Alguém sabe dizer se esse procedimento funciona no meu?
No momento estou usando o APP GFX toda vez que ligo o note, mas se uso o Chrome, ou Photoshop, ele altera para a dedicada, mesmo marcando a opção "apenas integrada". O app que desabilita a GPU via software aparentemente não funciona, mas mesmo assim o habilito ao ligar o note.

A dedicada é uma NVIDIA GEFORCE GT 330M

Sou novo aqui, e faz uma semana que tenho lido tudo que posso sobre este problema, e aprendendo muito com vocês, muito obrigado.

Também queria saber se alguém já fez a troca do capacitor, já li sobre, e vi que em alguns casos funcionou.

Obrigado aí gente.

Captura de Tela 2020-04-13 às 00.04.57.png

Ola boa tarde, o seu não vai dar certo porque o problema nao é a Gpu. 

O problema e um componente na placa mãe, se quiser eu faço reparo e resolvo o problema. 

Att - William 

11 99204-9496

Compartilhar este post


Link para o post
Compartilhar em outros sites
12 horas atrás, William Santos disse:

Ola boa tarde, o seu não vai dar certo porque o problema nao é a Gpu. 

O problema e um componente na placa mãe, se quiser eu faço reparo e resolvo o problema. 

Att - William 

11 99204-9496

Me fala mais sobre esse componente, nunca li nada sobre.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Reativando este post aqui. Alguém sabe dizer se esse procedimento funciona no meu?
No momento estou usando o APP GFX toda vez que ligo o note, mas se uso o Chrome, ou Photoshop, ele altera para a dedicada, mesmo marcando a opção "apenas integrada". O app que desabilita a GPU via software aparentemente não funciona, mas mesmo assim o habilito ao ligar o note.

A dedicada é uma NVIDIA GEFORCE GT 330M

Sou novo aqui, e faz uma semana que tenho lido tudo que posso sobre este problema, e aprendendo muito com vocês, muito obrigado.

Também queria saber se alguém já fez a troca do capacitor, já li sobre, e vi que em alguns casos funcionou.

Obrigado aí gente.
343399079_CapturadeTela2020-04-13s00_04_57.png.2fbda554c0ca233b37c87f53e730166f.png

Tenta usar esse aqui! https://github.com/fabioiop/MBP-2010-GPU-Panic-fix

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá, meu macbook tem esse defeito da placa de video, ja desativei e estou usando o catalina tranquilamente, porem comprei um adaptador para usar monitor externo, e não compartilha a tela, seria comum isso acontecer quando se tem o defeito da placa de video?

Compartilhar este post


Link para o post
Compartilhar em outros sites
7 minutos atrás, juliobuenopm disse:

Olá, meu macbook tem esse defeito da placa de video, ja desativei e estou usando o catalina tranquilamente, porem comprei um adaptador para usar monitor externo, e não compartilha a tela, seria comum isso acontecer quando se tem o defeito da placa de video?

Boa tarde, Julio. Salvo engano em aparelhos com GPU a Thunderbolt usa exclusivmente a GPU para gerenciar o espelhamento. Caso tenha interesse, eu faço o reparo desse defeito efetuando a troca do resistor responsável por esse defeito na placa lógica. No meu Instagram (@betoapplemga) tem imagens do procedimento no destaque "Linha Mac".

É um reparo simples porém demanda experiência e equipamento. Mesmo assim não é um procedimento caro e você nunca mais terá problemas, pois eu uso uma resistência maior do que a original de fábrica (que na verdade nada mais é do que um erro de projeto de quem projetou a placa). Eu uso a mesma resistência utilizada Apple nas placas que sucederam o seu modelo.

Entre em contato para orçamento.
WhatsApp: (44) 98823-5588

Abraço!

Editado por BetoGaleazzo

Compartilhar este post


Link para o post
Compartilhar em outros sites
2 horas atrás, juliobuenopm disse:

Olá, meu macbook tem esse defeito da placa de video, ja desativei e estou usando o catalina tranquilamente, porem comprei um adaptador para usar monitor externo, e não compartilha a tela, seria comum isso acontecer quando se tem o defeito da placa de video?

 

Boa tarde Julio, todos os Macs com Video dedicado, quem faz o gerenciamento da thunderbolt  e a Gpu. 
Se estiver em Sao Paulo, pode nos contatar. 
Att 

William

1199204-9496

Editado por William Santos

Compartilhar este post


Link para o post
Compartilhar em outros sites
Em 15/04/2020 at 19:20, Rafael Serrano disse:

Boa tarde pessoal, após desativar a GPU, vocês conseguem ajustar o brilho normalmente pelas teclas F1 e F2 ou vocês utilizam algum programa para criar uma camada de brilho escuro sobre a tela?

Após desabilitar o a Gpu, a máquina não baixa mais o brilho. 
O brilho fica sempre no máximo, porque é uma função exclusiva da Gpu e o thunderbolt também para de funcionar. 

Sao sequelas que ficam , mas a máquina fica confiável novamente . 

Compartilhar este post


Link para o post
Compartilhar em outros sites
1 hora atrás, William Santos disse:

Após desabilitar o a Gpu, a máquina não baixa mais o brilho. 
O brilho fica sempre no máximo, porque é uma função exclusiva da Gpu e o thunderbolt também para de funcionar. 

Sao sequelas que ficam , mas a máquina fica confiável novamente . 

William a minha funciona o brilho, com o catalina

Compartilhar este post


Link para o post
Compartilhar em outros sites
13 horas atrás, William Santos disse:

Não era pra funcionar, qual a forma usou para desabilitar o video ?

Se desabilitar pela linha de comando sim, mas salvo engano tem um patch que desabilita a GPU mas faz adaptação de algumas funções via software, umas delas é o brilho. Acho que o patch faz o mesmo procedimento pra ativar o controle de brilho pelo teclado que se usa nos hackintoshes (inclusive eu uso no meu hackintosh, pois uso teclado Apple nele)

https://github.com/Bensge/NativeDisplayBrightness

Editado por BetoGaleazzo

Compartilhar este post


Link para o post
Compartilhar em outros sites
11 horas atrás, BetoGaleazzo disse:

Se desabilitar pela linha de comando sim, mas salvo engano tem um patch que desabilita a GPU mas faz adaptação de algumas funções via software, umas delas é o brilho. Acho que o patch faz o mesmo procedimento pra ativar o controle de brilho pelo teclado que se usa nos hackintoshes (inclusive eu uso no meu hackintosh, pois uso teclado Apple nele)

https://github.com/Bensge/NativeDisplayBrightness

Vou dar uma olhada e testar, se funcionar aviso aqui... vlw 

Editado por William Santos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Conteúdo Similar

    • Por jvznl
      hackintosh Mojave
      i5-9400F
      RX580 8GB
      H310M S2P 2.0 Se alguém precisar de ajuda deixa nos comentários! Pergunta: Na hora de iniciar o mac ele da um glitch (travamento) na tela, enrosca alguma coisa no meu hardware, apaga a tela, liga de novo e inicia o Mojave. Alguém sabe o que pode estar acontecendo? Pergunta 2: Microfone não funciona. É driver de áudio? AppleALC já está instalado. Será que preciso do voodoo?
    • Por jvznl
      Olá familia,
      Tenho em casa um PC com as seguintes configurações:
      - Processador: Intel i5-9400F
      - Placa de vídeo: amd RX580 8GB
      - Memória RAM: crucial ballistix 16gb ddr4 2666mhz
      - Placa-Mãe Gigabyte H310M S2P 2.0
      Gostaria de saber se consigo fazer um hackintosh com essas configurações, qual sistema operacional escolher e como fazer.
      Por favor, me ajudem!
    • Por CAJP22
      Visão geral:
      MacBook Pro 13 - 2011
      Intel Core i7 - 8 GB de RAM
      Olá pessoal!
      Ontem a noite eu baixei uma atualização de rotina e quando reiniciei o Mac começou a apresentar falhas no vídeo e a VRAM foi para 3 mb.
      Tentei de tudo e não consegui solucionar o problema.
      Por favor pessoal, me ajudem!
       

    • Por bmsvendas
      CONFIGURAR CONFIGURADOR MODEM ARRIS TG862
      MANUAL E TUTORIAL COM INSTRUÇÕES + VÍDEO TUTORIAL + RASTREADOR DE CERTIFICADOS E MACS + SOFTWARES
      VEJA DETALHES NO SITE: http://bms-vendas.com/configurador-modem-arris-tg862

       

    • Por JvDaP
      Passeando essa semana pelos anúncios da OLX, vi um Apple Cinema Display de 20, porém estava sem o adaptador de energia. Pesquisando o valor de um usado, chegando a casa dos 500 conto no mercado livre, pensei em desistir de adquirir o monitor (baratinho 100 reais) por causa do valor do adaptador. 

      Lendo alguns tutoriais, descobri que é possível fazer uma ligação direta do monitor com uma fonte universal que serve para notebook e monitores LCD, com saída de 24v.

      Depois de 40 min de trabalho nos cabos, consegui mais um monitor pro meu Set up.
       


       

    • Por Nicolas Furtado de Queiroz
      Olá pessoal,
      Preciso fazer alguns tutoriais e preciso de um programa onde eu possa fazer marcações e desenhos na tela enquanto gravo...
      Qual me recomendam?
      Att
    • Por ConradoBhz
      Boa Tarde moçada,

      Esse é o meu primeiro post no FORUM e espero colaborar muito com o conteúdo produzido aqui..

      Hoje estou aqui para divulgar uma postagem que fiz com alguns plugins que são fundamentais para otimizar o tempo de desenvolvimento e tornar a vida do programador mais fácil! rs

      http://www.decom.ufop.br/imobilis/?p=3927

      Espero que seja útil para alguém e caso tenham dúvidas é só falarem! 
    • Por Ricardo Oliveira_32781
      Caros,
       
      nos do laboratorio iMobilis (http://www.decom.ufop.br/imobilis/) temos desenvolvido em todas plataformas moveis: (Android, WIndows Phone e IOS) e temos feito um trabalho continuo em divulgar tutoriais e guias para a comunidade brasileira a respeito do desenvolvimento das mesmas.
       
      Gostaria de divulgar nosso esforço em popularizar a programação IOS, fazendo  uma série bem completa de tutoriais: http://www.decom.ufop.br/imobilis/?tag=ios
       
      Se quiserem postar perguntas e duvidas, podemos trabalhar em esclarecer e fazer mais tutoriais
    • Por clenioluiz
      Vídeo com 7 dicas básicas de como adestrar o Finder. A maioria é de senso comum, mas, uma ou outra pode ser útil pra você!
       

    • Por iMarco A.
      Estou precisando fazer um app.. Para colocar Notificação em Push.. não é um super app.. Apenas para 100á 300pessoas(mais pessoas não vão "querer baixar") Porém precisa ser simples.. Quero um lugar que vcs fazer apps(gratuitos e fazem gratuitamente) simples porém bonitos! Por favor ajudem 

      Ah.. E tem que ser compatível em android.. Pois a maioria tem android ... Beleza?
  • Estatísticas do Fórum

    • Total de Tópicos
      49.695
    • Total de Posts
      421.418
×
×
  • Criar Novo...