Ir para conteúdo
  • Cadastre-se
UnderEu

Bug crítico no macOS 10.14.4 - E pra Apple, bem... "a culpa é minha!"

Posts Recomendados

Senta que lá vem um pouquinho de história.

 

Desde que atualizei meu MacBook para o macOS 10.14.4 (Build 18E226), notei o seguinte comportamento:

- Você usa o notebook normalmente durante um certo período. Daí vc precisa sair de perto do notebook, fecha a tampa, resolve a vida, abre a tampa, digita a senha e segue o jogo;

- Você repete esse processo umas 2 ou 3x, sempre na normalidade... até que na 4ª vez vc abre a tampa do notebook e a sessão carrega SEM PEDIR TUA SENHA!

E exatamente após isso:

- O processo loginwindow está travado no Monitor de Atividade (e não dá pra matar o processo, nem mesmo forçando);

- As teclas de função (brilho da tela, brilho do teclado, controle de volume, controles multimídia) param de funcionar;

- O app FaceTime não abre (anulando a possibilidade de atender ligações até no próprio iPhone);

- Vc não consegue desligar/reiniciar/fazer logoff no menu da maçã (Pop-up de confirmação não aparece).

Só com "dedoff" (vulgo Desligar no botão, de qualquer jeito) pra restaurar o comportamento correto até que o ciclo se repita.

 

E eis a parte assustadora do negócio:

* FileVault está LIGADO;

* Sistema está configurado p/ pedir minha senha IMEDIATAMENTE após o repouso;

* E tudo isso foi somente após a atualização do macOS para a versão 10.14.4 (18E226).

 

Reportei pra Apple no chat de suporte e tbm. por DM no Twitter @AppleSupport e essa foi a conversa (em resumo):

- "Vocêr já tentou atualizar pra última versão?" -_-'

- "Você já tentou reiniciar a máquina?" -_-' -_-'

- "Você já tentou resetar o SMC?" - Já

- "Você já tentou resetar a NVRAM?" - Já

- "Você já fez o teste com outro usuário logado na máquina?" - Já

- "Então, vou te pedir pra vc agendar um horário numa assistência pois tua máquina tá com defeito!" - Não, Apple... minha máquina não tá com defeito. Hardware dela tá funcionando perfeitamente e tudo isso passou a acotecer somente após essa atualização.

- "Então, não podemos fazer nada se você não agendar um horário em uma assistência para verificar tua máquina! Teu case está cancelado!".

 

E já que a Apple faz de tudo para inibir que o pessoal faça downgrade dos softwares dela (e também porque meu backup do Time Machine já foi atualizado com essa versão), tive q forçosamente baixar o Beta público do 10.14.5 (18F108f) e me livrar dessa brecha - até o momento, tudo normal - mas fica o alerta para quem estiver usando o macOS Mojave e por algum milagre não tiver atualizado pro 10.14.4 (18E226)... evitem!
E pra quem já atualizou, queria saber se já notaram o mesmo ou algo parecido?

É extremamente preocupante saber que o sistema não está protegendo a sessão do usuário devidamente, mesmo com criptografia de disco ativada, mesmo com as configurações forçando para que isso aconteça instantaneamente e a Apple, uma empresa do tamamho que é do valor que adquiriu, se faz de desentendida... bota a culpa no usuário... não admite que o software dela tá bichado... fala que "não tem nada que possa ser feito!", que "você está usando o teu equipamento errado!". E mesmo que haja Radar pra reportar esses bugs, ou eles caem num limbo temporal infinito para alguém dar qualquer resposta daqui uns 10 anos ou simplesmente fecham alegando que o problema já tá sendo tratado (famoso "Duplicate" - o que eu duvido MUITO que realmente esteja).

 

Só porque eu tava contente com o Mojave, até agora... 😕
Saudades, macOS Sierra

Editado por UnderEu

Compartilhar este post


Link para o post
Compartilhar em outros sites

O meu ainda esta na versão Mojave 10.14.3 mas pede todo dia para atualizar, estou teimando em fazer a atualização justo por medo de algum bug no sistema, como esta rodando liso tudo e tranquilo não vou cair nesta besteira. 

Obrigado pelo aviso UnderEU

Compartilhar este post


Link para o post
Compartilhar em outros sites

Problemas continuam no Developer Beta 5 (18F131a)

Desconfio de q seja algo relacionado esse processo aqui, q por acaso ele apareceu travado na última vez q precisei reiniciar forçadamente a máquina (vulgo há uma hora atrás): https://eclecticlight.co/2019/04/01/back-to-school-studentd-and-classroom-in-mojave-10-14-4


Bom, como é algo que eu nunca vou usar, destruí ele do meu sistema e vamo ver o q acontece.

Editado por UnderEu

Compartilhar este post


Link para o post
Compartilhar em outros sites

Atualização sobre o caso:

 

Depois de 40 e tantos dias passando raiva, testando e retestando tudo quanto é software instalado na minha máquina, reportando tudo quanto é dado de diagnóstico possível para a Apple num radar aberto (e eles não responderam, até agora)... fui investigar a fundo os arquivos de logs na esperança de q eu conseguisse entender alguma coisa em meio às mensagens guardadas.

Problema: o processo loginwindow ia crescendo o número de threads numa taxa de 1 a cada 10s até chegar no limite de 4096; daí o processo travava e iniciava-se os problemas que eu vinha enfrentando - confirmando a média de tempo que ele vinha travando: entre 2 ou 3 dias (que, por coincidência, era a mesma média de vezes que eu abro e fecho a tampa do MacBook). Normalmente, o loginwindow não consome mais que 2 threads.

Daí, lendo o arquivo /var/log/status.log , a seguinte mensagem estava se repetindo exatamente na mesma taxa que o número de threads do loginwindow crescia:

May 12 22:57:27 Unders-Macbook com.apple.xpc.launchd[1] (com.w0lf.dblockinjector): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

O processo relacionado (com.w0lf.dblockinjector) faz parte de um programa chamado Dark Boot, que troca a cor da tela de boot e personaliza os wallpapers da tela de bloqueio (coisa que o macOS não permite acesso por padrão). Aí, fui pesquisar a Internet afora até chegar nos issues do programa no GitHub e cheguei nesse link, onde a pessoa reportava o exatíssimo mesmo problema q eu tinha mas de uma data bem anterior a atualmente.
Mas aí, comecei a ler e vi que o cidadão reportou que o problema não era o Dark Boot mas sim outro programa chamado gfxCardStatus, cujo objetivo desse é controlar qual GPU está sendo usada nos Macs com opção de GPU dedicada (tipo, a minha máquina) - e eu também uso esse.
Alguma considerações: o gfxCardStatus já não é atualizado há alguns anos mas continuou funcionando pra mim normalmente na sua função principal, inclusive no macOS 10.14.4 e betas da 10.14.5 que usei - daí, me surgiu a pulga atrás da orelha, resolvei fazer o teste desinstalando esse por completo (tirando os arquivos no /Library, /System etc. ) e monitorando o comportamento.

E adivinha... desde esse domingo (12/05/2019), minha máquina tá perfeita; o processo loginwindow tá lá quietinho com seus 2 threads e não tem mais nenhuma ocorrência recorrente nos arquivos de logs. Tudo me leva a crer que, realmente, o problema é o gfxCardStatus - por desencargo, fui conferir as issues dele, não tem nada relacionado nem mesmo sinal de que vai sair alguma atualização e o fork mais atualizado teve o último release no ano passado (pré-Mojave).

 

Bom, se não travar mais até o final dessa semana, vou declarar meu problema como resolvido e já encontrei uma alternativa com suporte atualizado chamada gSwitch. Depois eu volto aqui, pra confirmar se tá resolvido em definitivo.

 


P.S.: E eu realmente achando que foi cagada da Apple, pela infeliz coincidência com a atualização 10.14.4 ... mas ainda mantenho minha crítica, achando q o problema tava no meu hardware e me fazendo marcar horário em assistência pra inventar um problema e me fazer deixar 2 costelas pra arcar com o custo =P

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Conteúdo Similar

    • Por zynshot
      Oi galera, tenho um Macbook Air 13” de 2009, White, velhinho que comprei na OLX e não me arrependo. 2 meses após a compra eu estava mexendo e percebi que ele estava conectado na tomada mas não carregava. Descarregou completamente e Pensei: Vou colocar em outra tomada, deve ser esse o problema. Mas agora o carregador não liga a luz dele e o Macbook não dá sinal de vida. O que eu quero saber de vocês é se o Macbook (mesmo sem bateria) dá algum sinal de vida, faz algum barulho, tenta iniciar, aparece “falta de energia” e desliga?  Vou comprar um novo carregador, mas tenho medo do problema ser no Mac. Por favor respondam se ele liga sem bateria pra eu não gastar dinheiro á toa hahahaha
    • Por Denis Augusto Ferreira
      Bom dia amigos!

      Acompanhando o forum em algumas pesquisas não encontrei resposta para minha duvida, sou novo usuário de Macs.
      Adquiri recentemente um Macbook Pro Mid 2012 (I5, 4GB Memoria) e ja encomendei um upgrade para colocar um SSD legal nele e aumentar a memória para 8GB.

      Tenho duas duvidas.

      - Primeiramente, qual versao do MAC OS vocês me recomendam para essa maquina? (Andei vendo sobre El Capitan ou High Sierra) mas, como marinheiro de primeira viagem no MAC fiquei em duvida.
       
      -  Segui um passo a passo para baixar a versão El Capitan criando o boot a partir do pen drive, porem quando vou selecionar o OS baixado no Diskmaker ele apresenta uma mensagem (This File cant be used to create a macOS installation disk).

      Agradeco desde Ja,

      Abracos!
    • Por Silvanio Duarte da Cruz
      Olá pessol, Tenho um MacBook Pro Meados de 2012  (SSD 240GB e 16GB Ram) onde eu estava usando o MacOS Mojave.
      Depois  de 1 ano usando esse OS Mojave do nada começou a parar de funcionar os navegadores e outros app,  tentei resolver mas não consegui, então resolvi reinstalar o MAC OS Mojave.
      Fiz backup dos arquivos e não do OS Mojave por estar com problema,  tentei atualizar  através do  Option + ⌘ + R para ter a versão compatível mais recente. Ele trouxe o Mac OS Catalina, formatei o HD e após instalar o sistema Catalina apareceu o simbolo de proibido 🚫 (Algo estranho pois a própria Apple entrega ele em Option + Comand + R.
      Baixei o Mojave, fiz o pendrive de boot e o instalei, depois de instalado recebo a mesma mensagem com o simbolo de Proibido 🚫 para o Mojave (Estranho pois era o sistema que eu estava usando a 1 ano).
      Então fiz a instalação com Comand + R, onde  ele instalou o Mountain Lion e após configurar o ID no App Store, quando tento atualizar o Mountain Lion só aparece o Catalina, porém diz que não pode baixar. Tentei instalar outras versões do Mac OS e ele não permite baixar os SOs.
      Coloquei o Catalina em um Pendrive e tentei descarregar na pasta Aplicativos do Mountain Lion, o aquivo dentro do pendrive fica com o simbolo de 🚫 não deixa copiar o arquivo.
      Ou seja, está preso no Mountain Lion. Diz compatível com Catalina, entrega o catalina como OS mais recente compatível mas não permite instalar.
      Alguém sabe o que pode estar causando isso? Preciso arrumar com urgência pois uso o Mac para trabalhar.
    • Por Cacá Andrade Rodrigues
      Pessoal, o Mojave para meu MacBook Pro 2016 não caiu bem, e resolvi fazer uma formatação e instalação limpa do Mojave.  
      Minha dúvida é sobre as senhas  salvas no chaves. Elas também vão para o iCloud quando eu for conectar novamente?
    • Por Zekrous
      Boa noite meus amigos, tudo bem ? espero que sim!
      seguinte, tenho um macbook pro mid 2010 rodando Mojave, instalado via patch
      Porem, apareceu uma atualização que eu posso instalar o catalina, minha duvida é,
      eu posso atualizar normalmente sem problema algum, ou teria que baixar o patch do catalina e instalar via patch novamente ?
       
      Desde já meu muito obrigado a todos =D
       
    • Por Zekrous
      Fala povo lindo, tudo certinho com vocês ? espero que sim
       
      Seguinte, eu tenho um macbook mid 2010, com SSD e 8GB de ram, vocês acham que vale atualizar via patch pata o Mojave ?
       
      Atualmente eu uso o High Sierra, ai não sei se vale a atualização, se roda liso como se tivesse atualizado normalmente, qual dica vocês me daria ?
       
      Desde já, muito obrigado 

    • Por Moiisesaraujo
      Fala galera, 
      Estou com um problema no meu MacBook, como coloquei no título ele é um MacBook Pro de 13’ Mid 2012. Ele liga, no entanto após iniciar, desliga sem fazer nenhum ruído. Pensei que fosse bateria, pois a mesma nunca foi trocada e já apresentava a mensagem para ser substituída. Abri-lo e desconectei o pug de bateria e tentei ligar. Começou a ligar normalmente e após a inicialização completa, desligou novamente, mesmo estando ligado só no cabo. Ou seja, minha teoria de problema na bateria em tese caiu. 
      Estava fazendo pesquisas para fazer alguns upgrades nele, mas com isso não sei o que faço.
      Qual seria a melhor opção??
       
      Agradeço a quem puder me ajudar. 
    • Por gaabrieloli
      Estava atualizando para o Catalina, quando reiniciou e ficou com essa tela. Já tentei todos os comandos (Command+R, Shift, etc..) e nada. Alguém pode ajudar ?

    • Por João Arthur
      Bom Dia galera, sou novo aqui no fórum e queria tirar umas duvidas...
      Eu tenho. um MBP 2009 rodando o High Sierra em um SSD de 120GB, tudo tranquilo ate agora.
      Recentemente tive uma ideia de fazer um dualboot nele, tanto windows como outro OSX mais antigo, e pra isso eu removi o meu drive de DVD e coloquei aqueles adaptadores internos pra colocar outro HD de 500GB, consegui fazer numa boa, meu MBP reconhece o HD e consigo usa-lo normalmente, mas ai me surgiu uma duvida, o HD interno que eu coloquei... posso instalar um sistema nele? o MBP vai reconhecer? e tambem tenho outra duvida... aparentemente depois de tirar meu Drive de DVD, nao consigo usar o assistente de Boot Camp para instalar o windows.... (imagem a baixo) Existe uma maneira de eu instalar o Windows (10 de preferência) neste HD ?

    • Por Jr Lobbo
      Amigos td beleza!? 
      Então, minha configuração é placa mãe  ga-q77m d2h , ram 32 ddr3 , Intel i5 3330 , rodava perfeitamente Mojave sem placa de vídeo com imagem do sistema do olarila só q ontem a tela congelou do nada (!!!) e o pc não liga mais , já testei memórias e fonte td certo , a placa eu vejo no bios q a data ta 2012 e não atualiza (!!) do nada o Mojave entrou e pedindo pra atualizar a data e do nada se desliga ... resultado: acho q a placa morreu , eu tentei achar uma parecida para não ter q formatar e refazer td porém não achei na minha cidade .... só  achei uma beeem parecida q é a Ga-Q67m d2h b3 será q essa vai rodar o Mojave ? Obrigado a vcs pela ajuda 
  • Estatísticas do Fórum

    • Total de Tópicos
      48.682
    • Total de Posts
      416.843
×
×
  • Criar Novo...