Ir para conteúdo
  • Cadastre-se
UnderEu

Bug crítico no macOS 10.14.4 - E pra Apple, bem... "a culpa é minha!"

Posts Recomendados

Senta que lá vem um pouquinho de história.

 

Desde que atualizei meu MacBook para o macOS 10.14.4 (Build 18E226), notei o seguinte comportamento:

- Você usa o notebook normalmente durante um certo período. Daí vc precisa sair de perto do notebook, fecha a tampa, resolve a vida, abre a tampa, digita a senha e segue o jogo;

- Você repete esse processo umas 2 ou 3x, sempre na normalidade... até que na 4ª vez vc abre a tampa do notebook e a sessão carrega SEM PEDIR TUA SENHA!

E exatamente após isso:

- O processo loginwindow está travado no Monitor de Atividade (e não dá pra matar o processo, nem mesmo forçando);

- As teclas de função (brilho da tela, brilho do teclado, controle de volume, controles multimídia) param de funcionar;

- O app FaceTime não abre (anulando a possibilidade de atender ligações até no próprio iPhone);

- Vc não consegue desligar/reiniciar/fazer logoff no menu da maçã (Pop-up de confirmação não aparece).

Só com "dedoff" (vulgo Desligar no botão, de qualquer jeito) pra restaurar o comportamento correto até que o ciclo se repita.

 

E eis a parte assustadora do negócio:

* FileVault está LIGADO;

* Sistema está configurado p/ pedir minha senha IMEDIATAMENTE após o repouso;

* E tudo isso foi somente após a atualização do macOS para a versão 10.14.4 (18E226).

 

Reportei pra Apple no chat de suporte e tbm. por DM no Twitter @AppleSupport e essa foi a conversa (em resumo):

- "Vocêr já tentou atualizar pra última versão?" -_-'

- "Você já tentou reiniciar a máquina?" -_-' -_-'

- "Você já tentou resetar o SMC?" - Já

- "Você já tentou resetar a NVRAM?" - Já

- "Você já fez o teste com outro usuário logado na máquina?" - Já

- "Então, vou te pedir pra vc agendar um horário numa assistência pois tua máquina tá com defeito!" - Não, Apple... minha máquina não tá com defeito. Hardware dela tá funcionando perfeitamente e tudo isso passou a acotecer somente após essa atualização.

- "Então, não podemos fazer nada se você não agendar um horário em uma assistência para verificar tua máquina! Teu case está cancelado!".

 

E já que a Apple faz de tudo para inibir que o pessoal faça downgrade dos softwares dela (e também porque meu backup do Time Machine já foi atualizado com essa versão), tive q forçosamente baixar o Beta público do 10.14.5 (18F108f) e me livrar dessa brecha - até o momento, tudo normal - mas fica o alerta para quem estiver usando o macOS Mojave e por algum milagre não tiver atualizado pro 10.14.4 (18E226)... evitem!
E pra quem já atualizou, queria saber se já notaram o mesmo ou algo parecido?

É extremamente preocupante saber que o sistema não está protegendo a sessão do usuário devidamente, mesmo com criptografia de disco ativada, mesmo com as configurações forçando para que isso aconteça instantaneamente e a Apple, uma empresa do tamamho que é do valor que adquiriu, se faz de desentendida... bota a culpa no usuário... não admite que o software dela tá bichado... fala que "não tem nada que possa ser feito!", que "você está usando o teu equipamento errado!". E mesmo que haja Radar pra reportar esses bugs, ou eles caem num limbo temporal infinito para alguém dar qualquer resposta daqui uns 10 anos ou simplesmente fecham alegando que o problema já tá sendo tratado (famoso "Duplicate" - o que eu duvido MUITO que realmente esteja).

 

Só porque eu tava contente com o Mojave, até agora... 😕
Saudades, macOS Sierra

Editado por UnderEu

Compartilhar este post


Link para o post
Compartilhar em outros sites

O meu ainda esta na versão Mojave 10.14.3 mas pede todo dia para atualizar, estou teimando em fazer a atualização justo por medo de algum bug no sistema, como esta rodando liso tudo e tranquilo não vou cair nesta besteira. 

Obrigado pelo aviso UnderEU

Compartilhar este post


Link para o post
Compartilhar em outros sites

Problemas continuam no Developer Beta 5 (18F131a)

Desconfio de q seja algo relacionado esse processo aqui, q por acaso ele apareceu travado na última vez q precisei reiniciar forçadamente a máquina (vulgo há uma hora atrás): https://eclecticlight.co/2019/04/01/back-to-school-studentd-and-classroom-in-mojave-10-14-4


Bom, como é algo que eu nunca vou usar, destruí ele do meu sistema e vamo ver o q acontece.

Editado por UnderEu

Compartilhar este post


Link para o post
Compartilhar em outros sites

Atualização sobre o caso:

 

Depois de 40 e tantos dias passando raiva, testando e retestando tudo quanto é software instalado na minha máquina, reportando tudo quanto é dado de diagnóstico possível para a Apple num radar aberto (e eles não responderam, até agora)... fui investigar a fundo os arquivos de logs na esperança de q eu conseguisse entender alguma coisa em meio às mensagens guardadas.

Problema: o processo loginwindow ia crescendo o número de threads numa taxa de 1 a cada 10s até chegar no limite de 4096; daí o processo travava e iniciava-se os problemas que eu vinha enfrentando - confirmando a média de tempo que ele vinha travando: entre 2 ou 3 dias (que, por coincidência, era a mesma média de vezes que eu abro e fecho a tampa do MacBook). Normalmente, o loginwindow não consome mais que 2 threads.

Daí, lendo o arquivo /var/log/status.log , a seguinte mensagem estava se repetindo exatamente na mesma taxa que o número de threads do loginwindow crescia:

May 12 22:57:27 Unders-Macbook com.apple.xpc.launchd[1] (com.w0lf.dblockinjector): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

O processo relacionado (com.w0lf.dblockinjector) faz parte de um programa chamado Dark Boot, que troca a cor da tela de boot e personaliza os wallpapers da tela de bloqueio (coisa que o macOS não permite acesso por padrão). Aí, fui pesquisar a Internet afora até chegar nos issues do programa no GitHub e cheguei nesse link, onde a pessoa reportava o exatíssimo mesmo problema q eu tinha mas de uma data bem anterior a atualmente.
Mas aí, comecei a ler e vi que o cidadão reportou que o problema não era o Dark Boot mas sim outro programa chamado gfxCardStatus, cujo objetivo desse é controlar qual GPU está sendo usada nos Macs com opção de GPU dedicada (tipo, a minha máquina) - e eu também uso esse.
Alguma considerações: o gfxCardStatus já não é atualizado há alguns anos mas continuou funcionando pra mim normalmente na sua função principal, inclusive no macOS 10.14.4 e betas da 10.14.5 que usei - daí, me surgiu a pulga atrás da orelha, resolvei fazer o teste desinstalando esse por completo (tirando os arquivos no /Library, /System etc. ) e monitorando o comportamento.

E adivinha... desde esse domingo (12/05/2019), minha máquina tá perfeita; o processo loginwindow tá lá quietinho com seus 2 threads e não tem mais nenhuma ocorrência recorrente nos arquivos de logs. Tudo me leva a crer que, realmente, o problema é o gfxCardStatus - por desencargo, fui conferir as issues dele, não tem nada relacionado nem mesmo sinal de que vai sair alguma atualização e o fork mais atualizado teve o último release no ano passado (pré-Mojave).

 

Bom, se não travar mais até o final dessa semana, vou declarar meu problema como resolvido e já encontrei uma alternativa com suporte atualizado chamada gSwitch. Depois eu volto aqui, pra confirmar se tá resolvido em definitivo.

 


P.S.: E eu realmente achando que foi cagada da Apple, pela infeliz coincidência com a atualização 10.14.4 ... mas ainda mantenho minha crítica, achando q o problema tava no meu hardware e me fazendo marcar horário em assistência pra inventar um problema e me fazer deixar 2 costelas pra arcar com o custo =P

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Conteúdo Similar

    • Por João Pedro Ramos
      Boa noite Pessoal,
      Estou enfrentando um problema na parte gráfica do meu notebook. Antes, o meu notebook só reconhecia 7MB dos 1536 MB e com muito lags (sem aceleração da intel). Revirei vários fóruns e sites para achar alguma maneira de resolver, até que achei um site (Link do Site) que explicava e disponibilizava as kexts que resolveram o problema, fazendo que o meu notebook reconhecer os 1536MB e ativando o QE/CI (Quartz Extreme and Core Image). 
      Mas ai começou outra dor de cabeça, primeiramente o meu sistema de áudio parou de funcionar, tentei reconfigurar com o sistema do VoodooHDA 2.9.2, funcionou e depois da primeira vez que reiniciei o notebook parou de funcionar por total.
      E a segunda dor de cabeça é que agora a tela do meu notebook vive com um glitchs bizarros, registrei em algumas fotos e um vídeo para vocês entenderem melhor. (Link das Fotos) (Link do Vídeo).
      Obs. Uso as vezes um adaptador HDMI>VGA para ligar um monitor de 21,5 Pol e quando ele está ligado, ele não apresenta este bug, é sempre o monitor principal do notebook que apresenta. Imaginei a primeira vista que fosse o cabo flat do notebook, mas depois de uns teste no sistema de diagnóstico da DELL mostrou que não havia nenhum defeito.
      Alguém já teve este problema ou tem a solução?
    • Por João Pedro Ramos
      Bom dia pessoal, tenho um Dell Inspiron 5547, I7-4510U com uma Intel Graphics 4400.
      Hoje eu inventei de deletar o arquivo kext Voodoocontrollerp2 pois eu achava que ele era o culpado do meu áudio estar tão baixo, depois disso eu reiniciei o PC e apareceu a mensagem que está na primeira foto. O meu teclado não funcionava mais e o sistema estava procurando outro via bluetooth.
      Gostaria de saber se existe algum meio de resolver esse erro desastroso que fiz via clover (Configs iniciais de boot)?
      * Sou novato no hackintosh, esse é o meu primeiro.
      * Touchscreen do notebook está funcionando normalmente.

    • Por João Gabriel Feldmann
      O modelo é um MacBook pro 2018 (touchbar)
       
      Está na versão 10.14.6
       
      foi atualizado hoje e começou a piscar a tela durante o uso
      Como posso proceder com esse problema?
       

    • Por FernandaRodrigues321
      Ola! Gente to com um problemao aqui no Mac OSX 10.6.8 Processador 2.93 GHZ Intel Core I7 | Memoria 4GB 1333 MHz DDR3 1TR de HD
      Comprei ele recentemente de um antigo dono que nao utilizava o mac e deixou ele no snow Leopard mesmo, acontece que eu 
      - Nao consigo baixar nada na apple store, pois recebo a seguinte mensagem O ARQUIVO DE DISTRIBUIÇÃO DO PRODUTO NAO PODE SER VERIFICADO. TALVEZ ESTEJA DANIFICADO OU NAO ESTAVA ASSINADO.
      Ja tentei trocar a conta mas nao adianta
      -NAO consigo restaurar usando os comando comd+R, o unico comando que ele responde usando o teclado na inicializacao e para a verificacao da memoria dele, que nao atesta nenhum erro
      -Ja baixei o arquivo do EL CAPITAN, o arquivo abre e pede pra ser colocado em um HD externo ou USB bootavel, mas com nenhuma das duas opcoes ele abre, so abre direto e so reconhece o HD do proprio Mac
      -Ja tentei reparticionar o HD mas ele tambem nao deixa
      -Eu estou usando um teclado do windowns, pode ser que por isso ele nao restaure?
      -O safari nao abre
       
       
    • Por ctrl_dias
      Olá, pessoal! 
      Estou precisando de ajuda com a instalação do High Sierra no notebook descrito no título do post, a questão é o seguinte: O sistema não sobe a instalação pois aparece erros de ACPI, mesmo eu seguindo os passos de instalação do site do Olarila. Então caso alguém tenha alguma EFI compatível ou orientações a respeito da instalação nesse hardware, ficarei grato. Qualquer duvida sobre erros específicos, kexts usadas, configuração atual da BIOS e coisas do tipo, responderei nos comentários. 
      Obrigado a quem tentar ajudar esse leigo que está quebrando a cabeça há uma semana.
      Configuração do Notebook no arquivo anexado. (AIDA64)
       
      Report.txt
    • Por willwalbr
      Começou nesse último sábado(18/5), ao tentar adicionar alguma álbum do Music à biblioteca do iTunes, ele abre uma nova janela(pequena) que fica carregando sem fim… Olhando pelo iPhone aconteceu a mesma coisa, mas a janela consegue carregar o conteúdo, que é uma janela sobre termos e condições, e pede que eu aceite. Depois disso tudo volta ao normal, mas como no Mac jamais carrega o conteudo, fico impossibilitado de fazer qualquer coisa que não seja escutar as músicas. Aconteceu com mais alguém? Alguma solução?
    • Por Marcos Lacerda
      Boa noite meu caros,
      Recentemente eu comprei um Time Capsule + Air Port de 2 TB.
      Confesso que estou apaixonado pelo produto, por ser de uma qualidade fora da curva.
      Agora estou com um "probleminha" que não consegui resolver pesquisando na web, e gostaria da ajuda dos colegas.
      É possível definir um diretório específico dentro do Time Capsule para salvar os bkps do Time Machine ???
      Como ele possuí 2 TB e o SSD do meu MacBook Pro é de 512 MB, não faz sentido eu reservar 100% do disco do TC para isso. Porém, o TM somente me permite selecionar um disco inteiro, fiz algumas pesquisas aqui e nenhuma das abordagens que encontrei funcionou.
      Então basicamente o que eu quero é poder criar uma pasta dentro do meu TC e com isso defini-la como destino do TM. Isso seria possível ou o TM somente trabalha com 100% do disco selecionado?
       
      Obrigado pela ajuda
      Abraços
    • Por ryanlameiro
      GPU Intel HD 4000 - reconhecida e funcionando perfeitamente
      WIFI Atheros AR9485 - funcionando perfeitamente
      Nenhum problema detectado até o momento!
      Quem quiser os arquivos e eventuais dicas para ter este setup funcionando, solicitar nos comentários!



    • Por Matheus Machado
      Boa tarde! Gostaria de saber se tem como atualizar o Snow Leopard para o El Capitan de alguma forma. Eu tenho um Macbook White 2,1 e pela App Store nÃo está sendo possível. Alguém pode me dar uma ajuda? 
    • Por jpcampos
      Meu iPhone 7 estava  com 127,4 de 128Gb ocupados e não fiz nenhum backup das ultimas 28.000 mídias aproximadamente, e precisava  atualizar o iOS  para ultima versão, a qual necessitava de 3,15Gb de armazenamento. Ao apagar fotos para liberar espaço elas voltavam instantaneamente então fui reiniciar o aparelho e ficou travado na tela da maçã.  Forcei reinicialização até o modo de restauração aparecer,  fui no iTunes e cliquei em  atualizar, onde a Apple dizia que tentaria reinstalar o iOS sem apagar os dados deu como concluído mas ao solicitar acesso ao celular pelo PC aparecia que não podia ser estabelecido., ou seja não foi reconhecido pelo iTunes.  A senha do meu IDApple estava no dispositivo e não me recordo, e demora muito tempo para eles se quer entrarem em contato. Alguém sabe o que devo fazer?
  • Estatísticas do Fórum

    • Total de Tópicos
      47.924
    • Total de Posts
      410.594
×
×
  • Criar Novo...