Ir para conteúdo
  • Cadastre-se

Posts Recomendados

Essa é a atualização mais inconveniente que eu já fiz num Mac.

Não faz uma semana que ela foi lançada e eu já tive mais problemas do que tive em todas as versões anteriores.

O Safari 5 travou (leia-se FECHOU) mais de 10 vezes (e só não conto precisamente pra não me aborrecer mais, hehehe).

Percebo que isso acontece quando clico em determinados links teoricamente inofensivos (exemplo: a "aba" Comunidades do Orkut).

Mais alguém vem enfrentando esse tipo de problema?

Por aqui só vi nego elogiando, e outros criticando por lentidão ou por não exibir determinados conteúdos (problemas que não senti).

Nunca enfrentei problema parecido, nem nos últimos dias usando a versão anterior. Isso está um pé no saco.

Abraços

Link para o post
Compartilhar em outros sites
  • Respostas 51
  • Criado
  • Última resposta

Top Postadores Neste Tópico

Top Postadores Neste Tópico

Imagens Postadas

Como assim, e se eu quiser ver um site em flash no Safari 5? hehehehe

Parte do relatório (Thread Crash)

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000048
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   com.apple.WebCore			 	0x00007fff8700cceb WebCore::nextCandidate(WebCore::Position const&) + 27
1   com.apple.WebCore			 	0x00007fff8700b58d WebCore::VisiblePosition::canonicalPosition(WebCore::Position const&) + 333
2   com.apple.WebCore			 	0x00007fff8700b310 WebCore::VisiblePosition::init(WebCore::Position const&, WebCore::EAffinity) + 48
3   com.apple.WebCore			 	0x00007fff870e165f WebCore::SelectionController::selectFrameElementInParentIfFullySelected() + 111
4   com.apple.WebCore			 	0x00007fff87132811 WebCore::EventHandler::handleMouseReleaseEvent(WebCore::MouseEventWithHitTestResults const&) + 209
5   com.apple.WebCore			 	0x00007fff871320c6 WebCore::EventHandler::handleMouseReleaseEvent(WebCore::PlatformMouseEvent const&) + 854
6   com.apple.WebCore			 	0x00007fff871bf07b WebCore::EventHandler::passSubframeEventToSubframe(WebCore::MouseEventWithHitTestResults&, WebCore::Frame*, WebCore::HitTestResult*) + 427
7   com.apple.WebCore			 	0x00007fff8730b9ab WebCore::EventHandler::passMouseReleaseEventToSubframe(WebCore::MouseEventWithHitTestResults&, WebCore::Frame*) + 11
8   com.apple.WebCore			 	0x00007fff87131fdc WebCore::EventHandler::handleMouseReleaseEvent(WebCore::PlatformMouseEvent const&) + 620
9   com.apple.WebCore			 	0x00007fff87131c34 WebCore::EventHandler::mouseUp(NSEvent*) + 228
10  com.apple.WebKit				  0x00007fff80bcee83 -[WebHTMLView mouseUp:] + 227
11  com.apple.AppKit				  0x00007fff83379fa5 -[NSWindow sendEvent:] + 5547
12  com.apple.Safari				  0x0000000100041bf9 0x100000000 + 269305
13  com.apple.Safari				  0x0000000100041b85 0x100000000 + 269189
14  com.apple.AppKit				  0x00007fff832af662 -[NSApplication sendEvent:] + 4719
15  com.apple.Safari				  0x00000001000388c6 0x100000000 + 231622
16  com.apple.AppKit				  0x00007fff832460aa -[NSApplication run] + 474
17  com.apple.AppKit				  0x00007fff8323ed7c NSApplicationMain + 364
18  com.apple.Safari				  0x0000000100009b1c 0x100000000 + 39708

Link para o post
Compartilhar em outros sites

Aqui tenho Mac OS X 10.6.3 + Safari 5 + Plugin Flash 10.0 r42

Só atualizei o Safari mesmo (considerando que a atualização do Mac OS X já tem um tempinho a mais).

Se o problema persistir (o que é BEM provável, né), considerarei essa possível alternativa "forçada" (que infelizmente não seria a ideal).

:)

Link para o post
Compartilhar em outros sites
Pois é...

Nunca tive esse tipo de problema com programa fechando "do nada" no Mac. Até hoje...

Eu tenho Chrome, Firefox, Opera e Camino aqui, mas preferi o Safari. Até hoje...

:)

Também não tenho nenhum problema e tenho quase todos esses navegadores instalados...

Pessoalmente,acho o Chrome bem melhor que o Safari, mais rápido e com inúmeras extensões que o safari não tem, dado o atraso de no minimo 4 anos para liberar as extensões.

Link para o post
Compartilhar em outros sites

É como eu disse, tenho outros navegadores... Não desgosto deles, mas o tópico é teoricamente pra saber quem vem enfrentando esse problema e eventualmente resolvê-lo. :P

Infelizmente escolher outro navegador não é bem uma solução para o problema dp app em si, bem como desinstalar o Flash Player também não seria.

Valeu

Link para o post
Compartilhar em outros sites

Reparar permissões depois de instalado o Flash, parece ajudar e/ou resolver.

As permissões diferem em "Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player", deveriam ser -rwxrwxr-x , elas são -rw-rw-r-- .
Reparado "Library/Internet Plug-Ins/Flash Player.plugin/Contents/MacOS/Flash Player".

LM

Editado por Lucky Man
Link para o post
Compartilhar em outros sites

Boa pergunta...

No meu Safari, depois que instalei o Flash, aparecia constantemente a "bolinha colorida", travava, enfim, praticamente não utilizável.

Consegui resolver assim:

1- "Passei" o Maintenance com as seguintes opções selecionadas:

post-10511-1276545572_thumb.png

Caso alguém tenha interesse em baixar o referido APP, link para download:

http://pagesperso-orange.fr/joel.barriere/...Maintenance.dmg

2- Reiniciei (quando o Maintenance termina as ações solicitadas, ele mesmo induz que o Mac seja reiniciado, bastando clicar em Restart).

3- Ato contínuo, reparei as permissões.

4- Safari voltou ao normal.

LM

Link para o post
Compartilhar em outros sites

Hum... Talvez seja por isso que você associou ao flash - por outro lado, não descarto inteiramente a possibilidade. O exemplo citado por mim no tópico como um dos contextos em que o Safari fechou - tentativa de acesso ao orkut - traz malditos banners em flash (que eu particularmente não gosto).

De qualquer forma, o Maintenance parece ser uma boa dica (geralmente falando).

Percebi que você reparou as permissões após o uso do mesmo. Por acaso você havia observado as permissões antes de usar o Maintenance?

Obs.: a "bolinha colorida" é linda, pena que quando aparece é sinal de alerta :P

Link para o post
Compartilhar em outros sites

Não observei, pois, até então, estava tudo OK.

Percebi que era o Flash, uma vez que os problemas começaram imediatamente após a instalação do mesmo.

Instalei e travou o Safari. Não tive dúvidas.

Busquei informações pela net e percebi que alguns usuários reclamavam acerca do problema (SL + Safari 5 + Adobe).

De qualquer sorte, até o momento, depois do que fiz acima, está tudo OK.

LM

Link para o post
Compartilhar em outros sites

Participe do debate

Você pode postar agora e se registrar depois. Se você tem uma conta, entre agora para postar com ela.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.




  • Estatísticas do Fórum

    • Total de Tópicos
      50.720
    • Total de Posts
      428.627
×
×
  • Criar Novo...