Ir para conteúdo
  • Cadastre-se
Entre para seguir isso  
Matheus F.

Erro iOS Simulator ao dar Run no Project

Posts Recomendados

Fala aí pessoal ;)

Xcode 4.3, baixado hoje mesmo. Quando dou Run, aparece isso:

Captura%20de%20Tela%202012-02-19%20%C3%A0s%2020.04.09.png

Já tentei selecionar a pasta do SDK em Switch SDK, mas não adiantou. Não é o Projeto, já testei com outros.

Alguma ideia?

Abraços :lol:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Parece que o ios simulator nao foi instalado direito.

Se voce baixou de qualquer outra forma que NAO seja da appStore baixe da AppStore. Pois sempre funciona.

Se o app veio diretamente da AppStore faça o senguinte:

Faz o seguinte quando o xcode estiver aberto vá em Preferences(Preferências)/Downloads se tiver um ios SDK na lista clique em //Check and install//

Para instalar o ios SDK.Espero ter ajudado. ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa Noite Rapahel :)

Baixei da App Store mesmo. O estranho é que o SDK tá "lá", visto que nem aparece pra baixar:

Captura%20de%20Tela%202012-02-19%20%C3%A0s%2022.06.45.png

Captura%20de%20Tela%202012-02-19%20%C3%A0s%2022.09.26.png

Vou tentar dar um delete nessa pasta, e ver se aparece pra baixar.

Editado por Matheus F.

Compartilhar este post


Link para o post
Compartilhar em outros sites

deletou a pasta developer ? o xcode 4.3 não usa mais ela ...

a imagem do simulador deve estar em

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/5.0/DeveloperDiskImage.dmg

Editado por Artur Felipe

Compartilhar este post


Link para o post
Compartilhar em outros sites

Fala aí Artur :)

Quando eu dou Run, abre o Simulator. Aí dá os dois erros. Se eu clico em Switch SDK, aparece o seguinte:

Captura%20de%20Tela%202012-02-20%20%C3%A0s%2012.23.46.png

Aí eu seleciono a pasta que você falou. Aí aparece o seguinte:

Captura%20de%20Tela%202012-02-20%20%C3%A0s%2012.25.02.png

Pelo que eu entendi, ele aceita o SDK, mas aí depois pede pra selecionar o App pra rodar nele... :wacko:

Vou tentar deletar esse DMG, e ver se aparece pra baixar de novo.

--

Não adiantou deletar :/

Ah, uma coisa que achei estranho:

Captura%20de%20Tela%202012-02-20%20%C3%A0s%2012.27.45.png

A pasta só tem 5MB! Tá certo isso?

Editado por Matheus F.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa Noite Rapahel :)

Baixei da App Store mesmo. O estranho é que o SDK tá "lá", visto que nem aparece pra baixar:

Captura%20de%20Tela%202012-02-19%20%C3%A0s%2022.06.45.png

Vou tentar dar um delete nessa pasta, e ver se aparece pra baixar.

Não era necessario deletar a pasta era so para clicar em "install" ao lado o ios simulator na primeira imagem.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não era necessario deletar a pasta era so para clicar em "install" ao lado o ios simulator na primeira imagem.

Sim, mas aí ele vai Instalar o 4.3, e eu quero o 5.0! :(

E eu coloquei as pastas de volta no lugar.

Editado por Matheus F.

Compartilhar este post


Link para o post
Compartilhar em outros sites

1) o problema acontece com qualquer projeto ? tentou criar um projeto novo e tentar rodar ?

2) errei no caminho do sdk no post anterior ... o caminho seria esse:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0.sdk (1.11 GB)

e em:

/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Applications

se encontra a aplicação do simulador em si ... iOS Simulator.app (4.4 MB).

Compartilhar este post


Link para o post
Compartilhar em outros sites

Opa Artur

1) Sim, com qualquer projeto :/

2) Tá aqui:

Captura%20de%20Tela%202012-02-22%20%C3%A0s%2009.09.23.png

Legal, quando eu abro o iOS Simulator.App, ele não mostra o erro do SDK, só pede pra selecionar o App pra rodar nele:

Captura%20de%20Tela%202012-02-22%20%C3%A0s%2009.16.49.png

Vou ver se consigo mais alguma coisa aqui.

--

Outra coisa: Quando dou Run no Projeto, o Xcode abre o iOS Simulator.app "certo"(mas continua com os erros do SDK):

Captura%20de%20Tela%202012-02-22%20%C3%A0s%2009.25.57.png

Editado por Matheus F.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Visitante
Responder este tópico…

×   Você colou conteúdo com formatação.   Remover formatação

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Limpar editor

×   You cannot paste images directly. Upload or insert images from URL.

Entre para seguir isso  

  • Quem Está Navegando   0 membros estão online

    Nenhum usuário registrado visualizando esta página.



  • Estatísticas do Fórum

    • Total de Tópicos
      48.871
    • Total de Posts
      417.047
×
×
  • Criar Novo...